3.0.19.i686 root password problem

Discuss installation issues/solutions for Engarde

Moderators: scrumpy, Dave, leihog

3.0.19.i686 root password problem

Postby vladut on Tue Jul 29, 2008 2:04 am

Hi all,

Is there a limitation in how log (number of chars) the root password should be in webtool interface?
I have a root password of 22 chars and I cannot logon with it in the console.
It also may be a problem using the special chars like &%$!
I have done about 4 clean installs now with the same result.
I can acces webtool (admin pass = 15 chars) but no root in console (or su -).
Now I will try reseting root password from live CD.
(later edit) In live cd I have tried:
mount /dev/hda2 /mnt
chroot /mnt
(setup new password for root)
The new password still not work :(
Posts: 6
Joined: Wed Nov 01, 2006 11:23 am

Re: 3.0.19.i686 root password problem

Postby wkeys on Fri Aug 01, 2008 8:55 am


Booting to the livecd normally should would I will try to look into this a little more.
Try mounting it as rw. Also you can try to editing the password manually /etc/shadow

Posts: 283
Joined: Thu Feb 01, 2007 5:43 pm

Re: 3.0.19.i686 root password problem

Postby georgied on Thu Aug 27, 2009 5:14 pm

I had the same problem and ended up doing 4 clean installs. It was driving me mad!!
There's definitely a limitation on the password length you can set through the web console. I eventually left it as lockbox then logged in the console (or ssh and su -) changed to sysadm_r and passwd my new password.

Code: Select all
engarde login:root
Your default context is root:staff_r:staff_t.

Do you want to choose a different one? [n]
Last login: Thu Aug 27 21:54:44 on tty1
[root@engarde ~]# newrole -r sysadm_r
Authenticating root.
[root@engarde ~]# passwd
New password:
Retype new password:
passwd: all authentication tokens updated successfully.

Hope this helps anyone else having the same problem.
Posts: 1
Joined: Thu Aug 27, 2009 4:58 pm

Return to Installation

Who is online

Users browsing this forum: No registered users and 3 guests