openssl-0.9.8k beta updates available

Discuss installation issues/solutions for Engarde

Moderators: scrumpy, Dave, leihog


Re: openssl-0.9.8k beta updates available

Postby leihog on Fri Feb 05, 2010 6:52 am

I'm assuming that openssl-perl-0.9.8k-1.x86_64.rpm and openssl-static-0.9.8k-1.x86_64.rpm aren't required.
The later is only useful if you need to compile against openssl, am I right?
leihog
 
Posts: 15
Joined: Mon Jun 26, 2006 2:33 pm
Location: Sweden

Re: openssl-0.9.8k beta updates available

Postby internetworks on Fri Feb 05, 2010 2:14 pm

Hello,

I tried to install it and I got this :

[root@server tmp]# rpm -Uvh openssl-0.9.8k-1.x86_64.rpm
error: Failed dependencies:
ca-certificates >= 2008-5 is needed by openssl-0.9.8k-1.x86_64
openssl = 0.9.8i is needed by (installed) openssl-devel-0.9.8i-1.x86_64
[root@server tmp]# apt-get remove openssl-devel
Reading Package Lists... Done
Building Dependency Tree... Done
The following packages will be REMOVED:
openssl-devel
0 upgraded, 0 newly installed, 1 removed and 0 not upgraded.
Need to get 0B of archives.
After unpacking 5480kB disk space will be freed.
Do you want to continue? [Y/n] y
Committing changes...
Preparing... ########################################### [100%]
Done.

[root@server tmp]# rpm -Uvh openssl-0.9.8k-1.x86_64.rpm
error: Failed dependencies:
ca-certificates >= 2008-5 is needed by openssl-0.9.8k-1.x86_64


Hope it can help.
internetworks
 
Posts: 41
Joined: Mon Mar 31, 2008 2:13 pm

Re: openssl-0.9.8k beta updates available

Postby leihog on Fri Feb 05, 2010 2:28 pm

You need this

http://ftp.engardelinux.org/pub/engarde ... noarch.rpm

It will work with that installed. :)
leihog
 
Posts: 15
Joined: Mon Jun 26, 2006 2:33 pm
Location: Sweden

Re: openssl-0.9.8k beta updates available

Postby internetworks on Sat Feb 06, 2010 12:22 am

leihog wrote:You need this

http://ftp.engardelinux.org/pub/engarde ... noarch.rpm

It will work with that installed. :)


Yes. It did. Thank you.

And it almost solved another problem I have with installing squid ( http://www.engardelinux.com/forums/viewtopic.php?f=6&t=1552&sid=b9dfc2912dab41c6c16a4209a493bf09 ) :

[root@server tmp]# rpm -Uvh ca-certificates-2009-2.noarch.rpm
Preparing... ########################################### [100%]
1:ca-certificates ########################################### [100%]
[root@server tmp]# rpm -Uvh openssl-0.9.8k-1.x86_64.rpm
Preparing... ########################################### [100%]
1:openssl ########################################### [100%]
[root@server tmp]# rpm -iv squid-3.0.STABLE23-1.x86_64.rpm
error: Failed dependencies:
libstdc++.so.6(GLIBCXX_3.4.6)(64bit) is needed by squid-3.0.STABLE23-1.x
86_64
[root@server tmp]#


Thanks.
internetworks
 
Posts: 41
Joined: Mon Mar 31, 2008 2:13 pm


Return to Installation

Who is online

Users browsing this forum: No registered users and 1 guest

cron