Starting ADSL after install

Discuss installation issues/solutions for Engarde

Moderators: scrumpy, Dave, leihog

Starting ADSL after install

Postby konsultex on Fri Dec 17, 2010 8:30 am

I'm trying to get EnGarde working inside Xen Cloud Platform (XCP version 0.5) so that I can improve my system. My installation of XCP is very stable even though at version 0.5 and I have several virtual machines running in it. I currently have OpenSUSE 11.1 running inside as a router but I want to replace it with an easier to administer with a browser and leaner distribution so I searched around and found EnGarde which looks like just what I need.

I dowloaded engarde-community-3.0.22.i686.iso and burned a CD with it. The install is being done using XenCenter to access XCP from the CD-ROM into a new virtual machine with 512 mb ram and 8 gb hard drive. My configuration has eth0 for the internal network and eth1 for external as ADSL. If I install configuring eth1 as pppoe I run into the same problems as reported here: ... NICs#p2456 regarding bit being able to install with PPPOE on one of the interfaces. So I reinstalled with eth1 as static. I did not select any of the additional modules (in previous tries I had tried it with all of them and with just firewall).

I can access the web tool over eth0. Since I'm on the internet during installation I got the activation key and set the adsl service to run on boot. The initial configuration went fine. I rebooted EnGarde figuring that I would then stop the other router (openSUSE) and reconfigure EnGarde eth1 as an ADSL connection. My problem is that the adsl service does not start and I suppose that this is why the network module configuration for eth1 does not show an option to configure as adsl.

I looked around in the system and found adsl-setup but when I run it it complains that rp-pppoe is not installed. I went back to the web tool to check but I saw that ppp was already installed. I suppose this is rp-pppoe. I installled the firewall, dns and dhcp packages and rebooted EnGarde. However I'm still stuck with the ADSL problem. I resintalled quite a few times with slightly different options but all roads eventually lead to not being able to use ADSL.

Is there some bug in this version? Am I doing something wrong? Does anything else have to be installed, started, configured for the adsl service to start?

Thanks a lot.
Posts: 1
Joined: Fri Dec 17, 2010 7:29 am

Re: Starting ADSL after install

Postby Dave on Thu Jan 13, 2011 8:10 pm

Hi, is the adsl service started? I don't think we have experience with XCP, but it works with Xen and KVM.

Try running "chkconfig --level 3 adsl on" and reboot.

Hope this helps.
Best regards,
Site Admin
Posts: 107
Joined: Tue Jun 13, 2006 6:06 pm

Return to Installation

Who is online

Users browsing this forum: No registered users and 1 guest