Error Configuring Snort in webtool

Discuss general troubleshooting concerns.

Moderators: scrumpy, Dave, leihog

Error Configuring Snort in webtool

Postby oiram on Fri Jun 01, 2007 3:26 am

Encountering the following error when trying to configure snort in webtool (engarde web interface).

Error - Missing Content-Type Header Can't exec "/etc/init.d/snortd": No such file or directory at /usr/webtool/modules/services/services.pm line 295.

Any suggestions?
oiram
 
Posts: 6
Joined: Fri Jun 01, 2007 3:21 am

RE: Error Configuring Snort in webtool

Postby oiram on Fri Jun 01, 2007 3:29 am

I'm running Engarde from the live CD. Haven't installed.
oiram
 
Posts: 6
Joined: Fri Jun 01, 2007 3:21 am

RE: Error Configuring Snort in webtool

Postby wkeys on Fri Jun 01, 2007 10:42 am

Can you please be more specific on what snort configure changes you did when the error happened. And was this a one time error or a error that keeps happening.

Thanks

~bk
wkeys
 
Posts: 283
Joined: Thu Feb 01, 2007 5:43 pm

RE: Error Configuring Snort in webtool

Postby oiram on Fri Jun 01, 2007 2:07 pm

I took the following steps:

1. In Gaurdian Digital Webtool I followed the path - system>Intrusion Detection Systems>Network IDS.

2. On the Network IDS page I followed the path - module>Snort Configuration

- Once in the Snort Configuration Page -

3. I checked the check box for eth0 under "Interfaces to Monitor"

4. I then identified under "Internal Networks" the network xxx.xxx.xxx.xxxx/24.

5. I then clicked "Update Configuration"

I then get the following error:

Error - Missing Content-Type Header

Can't exec "/etc/init.d/snortd": No such file or directory at /usr/webtool/modules/services/services.pm line 295.
Can't find label done at /usr/webtool/modules/services/services.pm line 295.

I have tried several times and the error is reoccurring.

I'm running EnGarde from the Live CD. I haven't installed to OS permanently. Looking at that error and after doing some searching around it seems to indicate that snort isn't installed. Should I be able to run snort from the Live CD without permanently installing the OS? Any suggestions will be well appreciated.
oiram
 
Posts: 6
Joined: Fri Jun 01, 2007 3:21 am

RE: Error Configuring Snort in webtool

Postby oiram on Fri Jun 01, 2007 2:09 pm

By the way that's xxx.xxx.xxx.xxx/24 not xxx.xxx.xxx.xxxx/24. Extra "x." Typo, you know.
oiram
 
Posts: 6
Joined: Fri Jun 01, 2007 3:21 am

RE: Error Configuring Snort in webtool

Postby wkeys on Fri Jun 01, 2007 3:27 pm

Just tried running snort off the live CD and you are right it's not installed and it's not part of the liveCD. But if you install it on a harddrive then snort will be installed :-) and should not through those errors.

~bk
wkeys
 
Posts: 283
Joined: Thu Feb 01, 2007 5:43 pm

RE: Error Configuring Snort in webtool

Postby oiram on Fri Jun 01, 2007 3:48 pm

Ah... that's somewhat disappointing. Would be nice to be able to use snort from the live cd. Perhaps in a future release.
oiram
 
Posts: 6
Joined: Fri Jun 01, 2007 3:21 am

RE: Error Configuring Snort in webtool

Postby oiram on Fri Jun 01, 2007 3:49 pm

BTW thanks!
oiram
 
Posts: 6
Joined: Fri Jun 01, 2007 3:21 am


Return to General Troubleshooting

Who is online

Users browsing this forum: No registered users and 1 guest

cron