bugtraq June 2008 archive
Main Archive Page > Month Archives  > bugtraq archives
bugtraq: Windows Installer msiexec GUID Buffer Overflow

Windows Installer msiexec GUID Buffer Overflow

From: Patrick Webster <patrick_at_nospam>
Date: Tue Jun 03 2008 - 10:12:37 GMT
To: bugtraq@securityfocus.com


aushack.com - Vulnerability Advisory



Release Date:
 03-Jun-2008

Software:
 Microsoft Corporation - Windows Installer (msiexec.exe)  http://www.microsoft.com/

 "Microsoft Windows Installer is an installation and configuration service that   reduces the total cost of ownership. Windows Installer enables customers to   provide better corporate deployment and provides a standard format for   component management."

Versions tested:
 4.5.6001.22159 and 3.1.4000.1823 are vulnerable.  Other versions are untested but assumed.

Vulnerability discovered:

 Unicode based stack overflow.

Vulnerability impact:

 Moderate - Code execution is possible but difficult due to the unicode conversion. Some ActiveX controls pass the GUID, so it may be exploited remotely. Other avenues may also be present.

Vulnerability information:

 By specifying an overly long Globally Uniquie Identifier (GUID),  it is possible to overwrite the stack and SE Handler.

 Example:

  msiexec.exe /x {<a few thousand A's>}

References:
 aushack.com advisory
 http://www.aushack.com/200806-msiexec.txt

Credit:
 Patrick Webster ( patrick@aushack.com )

Disclosure timeline:
 03-Jun-2008 - Disclosure.

EOF