bugtraq June 2008 archive
Main Archive Page > Month Archives  > bugtraq archives
bugtraq: [ MDVSA-2008:120 ] - Updated nasm packages fix vulnerab

[ MDVSA-2008:120 ] - Updated nasm packages fix vulnerability

From: <security_at_nospam>
Date: Sat Jun 21 2008 - 19:39:00 GMT
To: bugtraq@securityfocus.com

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1


  Mandriva Linux Security Advisory MDVSA-2008:120  http://www.mandriva.com/security/
  Package : nasm Date : June 21, 2008 Affected: 2008.1
_______________________________________________________________________

 Problem Description:  

 An off-by-one error was found in nasm 2.02 that allowed  context-dependent attackers to cause a denial of service (crash)  or possibly execute arbitrary code via a crafted file that triggers  a stack-based buffer overflow (CVE-2008-2719).  

 The updated packages have been patched to prevent this issue.


 References:  

 http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-2719


 

 Updated Packages:  

 Mandriva Linux 2008.1: e1341726c74cee725268e292736163e8 2008.1/i586/nasm-2.02-1.1mdv2008.1.i586.rpm 44741f5580b9b7e64fecc26814590302 2008.1/i586/nasm-doc-2.02-1.1mdv2008.1.i586.rpm 9a52325d2063b8e6461cc110bf5c99fe 2008.1/i586/nasm-rdoff-2.02-1.1mdv2008.1.i586.rpm 4e9ca678761155cdd0fcbc47b99e1ffe 2008.1/SRPMS/nasm-2.02-1.1mdv2008.1.src.rpm

 Mandriva Linux 2008.1/X86_64: a0658241d5d1bd9d0757b20cd1b49619 2008.1/x86_64/nasm-2.02-1.1mdv2008.1.x86_64.rpm c4097b75d9d9fbc85543aa005da7e78e 2008.1/x86_64/nasm-doc-2.02-1.1mdv2008.1.x86_64.rpm b5f13c0f7ca800623c7858451fdd9891 2008.1/x86_64/nasm-rdoff-2.02-1.1mdv2008.1.x86_64.rpm 4e9ca678761155cdd0fcbc47b99e1ffe 2008.1/SRPMS/nasm-2.02-1.1mdv2008.1.src.rpm
_______________________________________________________________________

 To upgrade automatically use MandrivaUpdate or urpmi. The verification  of md5 checksums and GPG signatures is performed automatically for you.

 All packages are signed by Mandriva for security. You can obtain the  GPG public key of the Mandriva Security Team by executing:

  gpg --recv-keys --keyserver pgp.mit.edu 0x22458A98

 You can view other update advisories for Mandriva Linux at:

  http://www.mandriva.com/security/advisories

 If you want to report vulnerabilities, please contact

  security_(at)_mandriva.com


 Type Bits/KeyID Date User ID
 pub 1024D/22458A98 2000-07-10 Mandriva Security Team   <security*mandriva.com>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)

iD8DBQFIXS6SmqjQ0CJFipgRArw/AJ9JN5IsKHikbipGthDCPCyFrVEzhgCdFrWu VhB5i3zSNivqytG/V/Ii8F4=
=T4Ra
-----END PGP SIGNATURE-----