bugtraq June 2008 archive
Main Archive Page > Month Archives  > bugtraq archives
bugtraq: Rhythmbox Vulnerability

Rhythmbox Vulnerability

From: <jplopezy_at_nospam>
Date: Thu Jun 26 2008 - 04:14:31 GMT
To: bugtraq@securityfocus.com
('binary' encoding is not supported, stored as-is)
Application: Rhythmbox 0.11.5
OS: Linux - Ubuntu 8.04
1 - Description 2 - Vulnerability 3 - POC/EXPLOIT
------------------------------------------------------
Description

Rhythmbox is a renowned player of mp3 files that comes bundled in ubuntu. What makes this vulnerability so dangerous is that it comes as default in ubuntu is quite possible that creating malicious file is opened with this player.



Vulnerability

The vulnerability works when a file of reproduction specially trained is created this causes the program to break.

Analyzing in more detail the failure with a debugger you can see the flaw in the segment but you cannot see precisely which function fails.

0x0844a767 in? ()



POC/EXPLOIT For a proof of concept you should create a file with the extension of reproduction (pls) and put the following content.

[playlist]
X-GNOME-Title=
Title= A * 1475
NumberOfEntries=0



Juan Pablo Lopez Yacubian