clamav-users August 2007 archive
Main Archive Page > Month Archives  > clamav-users archives
clamav-users: Re: [Clamav-users] Upgrade from version: 0.88.7 to

Re: [Clamav-users] Upgrade from version: 0.88.7 to version: 0.91.1 on FC6 error.

From: Graeme Nichols <gnichols5_at_nospam>
Date: Wed Aug 15 2007 - 03:20:19 GMT
To: "ClamAV users ML" <clamav-users@lists.clamav.net>


On 15/08/07, Andrew Petrushanco <andrew@guzzware.com.au> wrote:
>
> Hello All
>
>
>
> New User here. I'm having a problem when i try to upgrade my standard FC6
> installed Clamav from 0.88.7 to 0.91.1. I'm following the instructions
> from
> http://wiki.clamav.net/Main/RedHatInstall
>
>
>
> [root@ Fedora6 RPMs]# rpm -Uvh clamav-0.90.3-1.i386.rpm
> clamav-db-0.90.3-1.i386.rpm clamav-devel-0.90.3-1.i386.rpm
> clamav-server-0.90.3-1.i386.rpm
>
> error: Failed dependencies:
>
> libcrypto.so.5 is needed by clamav-0.90.3-1.i386
>
> libssl.so.5 is needed by clamav-0.90.3-1.i386
>
> libclamav.so.1 is needed by (installed)
> clamav-milter-0.88.7-3.fc6.i386
>
> clamav-server = 0.88.7-3.fc6 is needed by (installed)
> clamav-server-sysv-0.88.7-3.fc6.i386
>
> [root@Fedora6 RPMs]#
>
>
>
> Have done a lot of searching but found nothing so far to indicate what
> other
> packages i am missing.
>
>
>
> Thanks in Andrew Petrushanco
>
> Purchasing Officer
>
> GUZZWARE Pty Ltd
>
> Mob:0407 624 243
>
> Andrew

Hello Andrew,

The errors you are getting mean that you can't upgrade because some installed items are needed by your existing version of calmav.

Uninstall your existing version of clamav and then install the new version. It has worked for me before.

Cheers,

Graeme.



> Help us build a comprehensive ClamAV guide: visit http://wiki.clamav.net
> http://lurker.clamav.net/list/clamav-users.html
>
-- Kind Regards, Graeme. _______________________________________________ Help us build a comprehensive ClamAV guide: visit http://wiki.clamav.net http://lurker.clamav.net/list/clamav-users.html