fedora-users October 2011 archive
Main Archive Page > Month Archives  > fedora-users archives
fedora-users: Re: Configuring new ethernet interfaces

Re: Configuring new ethernet interfaces

From: Digimer <linux_at_nospam>
Date: Wed Oct 05 2011 - 02:00:58 GMT
To: Community support for Fedora users <users@lists.fedoraproject.org>

On 10/04/2011 09:51 PM, Alex wrote:
> Hi,
>
> I have an existing fedora15 x86_64 server with two interfaces that
> I've moved to a different motherboard and processor with dual onboard
> Intel 1000mbs ethernet controllers on it (e1000e driver). After moving
> the system to the new motherboard, for some reason the ethernet
> interfaces changed from eth0 and eth1 to eth4 and eth5.
>
> Why did this happen, and how do I change it back to eth0 and eth1?
>
> It looks like udev has something to do with this?
>
> Thanks,
> Alex

The MAC addresses changed. Take a look at this:

https://alteeve.com/w/Changing_the_ethX_to_Ethernet_Device_Mapping_in_EL6_and_Fedora_12%2B

(it's more or less the same in Fedora 15 and should apply)

-- Digimer E-Mail: digimer@alteeve.com Freenode handle: digimer Papers and Projects: http://alteeve.com Node Assassin: http://nodeassassin.org "At what point did we forget that the Space Shuttle was, essentially, a program that strapped human beings to an explosion and tried to stab through the sky with fire and math?" -- users mailing list users@lists.fedoraproject.org To unsubscribe or change subscription options: https://admin.fedoraproject.org/mailman/listinfo/users Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines