metasploit-framework October 2011 archive
Main Archive Page > Month Archives  > metasploit-framework archives
metasploit-framework: Re: [framework] Problem with MSF on MacOSX

Re: [framework] Problem with MSF on MacOSX 10.8

From: Marcus Twain <marcus.twain_at_nospam>
Date: Sat Oct 01 2011 - 13:55:48 GMT
To: Josh Little <josh@zombietango.com>

On Fri, Sep 30, 2011 at 08:53, Josh Little <josh@zombietango.com> wrote:
>
> On Sep 30, 2011, at 2:01 AM, Marcus Twain wrote:
>
>>
>> I apologize, I'm running 10.6.8 (which has the 10.8 kernel). This is a
>> standard build as delivered from Apple with no weird hacks.
>>
>>> zornhau:~ josh$ ruby -v
>>> ruby 1.9.2p290 (2011-07-09 revision 32553) [x86_64-darwin11]
>>
>> Hmm, we have different versions of ruby...
>
> Some of that may have been because my Ports version was old. I just did a self-update and a new ruby package was part of that. It, however, had no effect on my ability to run metasploit.
>
[..]

> sudo port uninstall rb-rubygems
>
> I don't believe, based on the fact that mine works in a similar enough environment, that there is a direct incompatibility with MS and the ruby 1.9 build in Mac Ports.

Well, I fixed the issue by trying different versions of ruby. Gem was
also the problem.

$ ruby --version
ruby 1.8.7 (2011-06-30 patchlevel 352) [i686-darwin10]

$ gem --version
1.3.7

$ port list installed | grep ruby
rb-mysql @2.7.5 ruby/rb-mysql
rb-rubygems @1.3.7 ruby/rb-rubygems
ruby @1.8.7-p352 lang/ruby

That seemed to get me working and allow me to load the mysql db_driver.
_______________________________________________
https://mail.metasploit.com/mailman/listinfo/framework