openssh-unix-dev August 2011 archive
Main Archive Page > Month Archives  > openssh-unix-dev archives
openssh-unix-dev: Re: Call for testing: OpenSSH-5.9

Re: Call for testing: OpenSSH-5.9

From: Kevin Brott <kevin.brott_at_nospam>
Date: Thu Aug 18 2011 - 06:29:15 GMT
To: Morty Abzug <morty@frakir.org>

On Wed, Aug 17, 2011 at 23:08, Morty Abzug <morty@frakir.org> wrote:

> On Sun, Aug 14, 2011 at 10:30:10AM +1000, Damien Miller wrote:
>
> > OpenSSH 5.9 is almost ready for release, so we would appreciate
> > testing on as many platforms and systems as possible. This release
> > contains a couple of new features and changes and bug fixes. Testing
> > of the new sandboxed privilege separation mode (see below) would be
> > particularly appreciated.
>
> On Solaris 9, make tests failed. The last few lines are:
>
> run test connect.sh ...
> ok simple connect
> run test proxy-connect.sh ...
> ok proxy connect
> run test connect-privsep.sh ...
> Connection closed by UNKNOWN
> ssh privsep/sandbox+proxyconnect protocol 2 failed
> failed proxy connect with privsep
> make[1]: *** [t-exec] Error 1
> make[1]: Leaving directory `/export/home/morty/src/openssh/regress'
> make: *** [tests] Error 2
>
> On Solaris 10, same failure:
>
> run test connect.sh ...
> ok simple connect
> run test proxy-connect.sh ...
> ok proxy connect
> run test connect-privsep.sh ...
> Write failed: Broken pipe
> ssh privsep/sandbox+proxyconnect protocol 1 failed
> Write failed: Broken pipe
> ssh privsep/sandbox+proxyconnect protocol 2 failed
> failed proxy connect with privsep
> make[1]: *** [t-exec] Error 1
> make[1]: Leaving directory `/export/home/morty/src/openssh/regress'
> make: *** [tests] Error 2
>
> Both are with openssh-SNAP-20110818.tar.gz, ./configure --with-pam.
>
> On the plus side, ssh to various ScreenOS versions succeeds.
> Presumably this is due to RequestTTY=auto making PTY allocation
> failure non-fatal again.
>
> scp to ScreenOS is still broken.
>
>
Got the same 'make tests' error on all versions of HP-UX from 11.11 to 11.31
on IA64 & PA-RISC, but not RH/Ubuntu Linux or AIX. Given that 5.8 didn't
have this problem, odds-on it's a recent change in privsep (or the test for
it) that's maybe making an assumption not valid on HP-UX/Solaris.

-- # include <stddisclaimer.h> /* Kevin Brott <Kevin.Brott@gmail.com> */ _______________________________________________ openssh-unix-dev mailing list openssh-unix-dev@mindrot.org https://lists.mindrot.org/mailman/listinfo/openssh-unix-dev