postfix-users October 2010 archive
Main Archive Page > Month Archives  > postfix-users archives
postfix-users: relay through gateway not localhost

relay through gateway not localhost

From: Cameron Smith <velvetpixel_at_nospam>
Date: Tue Oct 05 2010 - 17:57:39 GMT
To: postfix users list <postfix-users@postfix.org>

I am trying to set up a mail system with a gateway to be used as the
outbound relay point for 10 mail servers on our LAN.

When sending mail from one of the servers I get a status of sent but it
shows this in the log:

relay=[127.0.0.1]

So the mail never reaches the gateway.

Here is my postconf:
[root@dev ~]# postconf -n
alias_database = hash:/etc/aliases
alias_maps = hash:/etc/aliases
command_directory = /usr/sbin
config_directory = /etc/postfix
daemon_directory = /usr/libexec/postfix
debug_peer_level = 2
html_directory = no
inet_interfaces = all
mail_owner = postfix
mailq_path = /usr/bin/mailq.postfix
manpage_directory = /usr/share/man
mydestination = $myhostname, localhost.$mydomain, localhost
mydomain = example.com <-------changed from actual for this post.
myhostname = dev.exm.loc
mynetworks = 127.0.0.0/8, 10.0.132.0/24
newaliases_path = /usr/bin/newaliases.postfix
queue_directory = /var/spool/postfix
readme_directory = /usr/share/doc/postfix-2.3.3/README_FILES
relay_domains =
relayhost = [10.0.132.15]
sample_directory = /usr/share/doc/postfix-2.3.3/samples
sendmail_path = /usr/sbin/sendmail.postfix
setgid_group = postdrop
transport_maps = hash:/etc/postfix/transport
unknown_local_recipient_reject_code = 550