postfix-users October 2010 archive
Main Archive Page > Month Archives  > postfix-users archives
postfix-users: Re: SMTP relay and greylisting

Re: SMTP relay and greylisting

From: Michael Orlitzky <michael_at_nospam>
Date: Tue Oct 26 2010 - 15:32:14 GMT
To: postfix-users@postfix.org

On 10/25/10 23:35, utahnix wrote:
> On 10/25/2010 9:05 PM, Michael Orlitzky wrote:
>> On 10/25/2010 10:38 PM, utahnix wrote:
>>> Hello all,
>>>
>>> Anyway, I've set up greylisting with Postgrey to help cut down on the
>>> junk mail that I get. I've set it up with default values (deferral of
>>> 300 seconds, etc). Well all seems good and fair except some of my
>>> regular senders can't seem to get their email through. I've checked my
>>> server logs and I don't even see their email address mentioned (it
>>> doesn't appear to even reach my machine). Several of the emails in
>>> question are Yahoo or Gmail. What's odd is that I have both a Yahoo
>>> account and a Gmail account, and I can send myself mail with no problems.
>>>
>>> I disabled Postgrey temporarily and had these senders re-send test
>>> messages from their addresses, and it worked (I got their messages). So
>>> something was certainly hanging things up. I just wish I knew what that was.
>>
>> Do you have "smtpd_delay_reject = yes" set? If so, you should be able to
>> see the senders' addresses in your logs even if they were greylisted.
>
> Yes I do, actually.
>

The blacklisting is a separate issue (haven't had time to look through
the postconf yet), but if you have this set and aren't seeing the
senders' addresses in your logs, they're screwing something up. A typo
in your domain name, maybe?