spamassassin-dev October 2011 archive
Main Archive Page > Month Archives  > spamassassin-dev archives
spamassassin-dev: [Bug 6681] NetAddr-IP version above 4.048 brea

[Bug 6681] NetAddr-IP version above 4.048 break sa-update

From: <bugzilla-daemon_at_nospam>
Date: Wed Oct 26 2011 - 16:13:40 GMT
To: dev@spamassassin.apache.org

https://issues.apache.org/SpamAssassin/show_bug.cgi?id=6681

--- Comment #19 from Todd Rinaldo <toddr@cpanel.net> 2011-10-26 16:13:40 UTC ---
> The issue stems from an incompatibility between NetAddr::IP starting at version
> 4.049 and Socket6 prior to version 0.23. A holdback is currently in place
> preventing NetAddr::IP from updating past 4.048 with cPanel scripts.
4.049 was a separate issue. In that case, NetAddr::IP wouldn't even install
when Socket6 0.20 was installed.

> The holdback (which was removed briefly today when it was believed that
> NetAddr::IP. version 4.050 would resolve the issue) should prevent the issue from
4.050 created a new issue where Socket6 and NetAddr::IP would install but then
saupdate and company would not run on some systems. It seems to be 64bit only
systems as best I can tell. Mark reports he's having no problems on a64bit but
I do note that Mark is running on BSD, not Linux so the problem may be tied to
linux.

-- Configure bugmail: https://issues.apache.org/SpamAssassin/userprefs.cgi?tab=email ------- You are receiving this mail because: ------- You are the assignee for the bug.