spamassassin-users October 2010 archive
Main Archive Page > Month Archives  > spamassassin-users archives
spamassassin-users: Re: Perl IO::Socket::INET6

Re: Perl IO::Socket::INET6

From: Mark Martinec <Mark.Martinec+sa_at_nospam>
Date: Wed Oct 06 2010 - 16:26:03 GMT
To: users@spamassassin.apache.org

John,

> > Updating to a recent version of IO::Socket::INET6 would probably
> > solve the issue and would be advised anyway - the 2.51 is pretty
> > ancient, from October 2004.
>
> Thanks. Updating to 2.63 did indeed solve the problem. I'll file a
> gentoo bug to get the version dependencies properly sorted. Does anyone
> have an authoritative reference to minimum required module versions for SA?

The SpamAssassin DependencyInfo only claims:

  module IO::Socket::INET6

  This is required if the first nameserver listed in your IP
  configuration or /etc/resolv.conf file is available only via an
  IPv6 address. Also used by a DCC plugin to access dccifd over network

The minimal version is not prescribed as far as SpamAssassin is
concerned - as long as its bugs do not interfere with its operation.

The current version is 2.65 (June 2010). I'd say the minimal
version should be 2.62, based on its release notes:

2010-05-20 Shlomi Fish <shlomif@iglu.org.il>
        * Solved "problems with multihomed and family order"
                - https://rt.cpan.org/Ticket/Display.html?id=57676
                - Thanks to Steffen Ullrich
        * New Release IO-Socket-INET6-2.62

Mark