spamassassin-users October 2010 archive
Main Archive Page > Month Archives  > spamassassin-users archives
spamassassin-users: Re: ALL_TRUSTED

Re: ALL_TRUSTED

From: Bob Proulx <bob_at_nospam>
Date: Sat Oct 23 2010 - 17:15:48 GMT
To: users@spamassassin.apache.org

Casartello, Thomas wrote:
> I'm having an issue with the ALL_TRUSTED rule in SA 3.3.1. I
> recently rebuilt my server running SA, and now for some reason the
> ALL_TRUSTED rule is not triggering when a user sends a message using
> SASL authentication from outside our site. Before it would work when
> the sending IP matched our trusted networks list, and if the person
> sent directly through our server using SASL from off site. Now the
> SASL from off site doesn't make the rule trigger so we are getting a
> lot of false positives. Any help would be appreciated.

Browse through this following documentation.

  http://wiki.apache.org/spamassassin/TrustPath

  http://wiki.apache.org/spamassassin/TrustedRelaysDebugExample

  http://wiki.apache.org/spamassassin/HowToDebug

Then run 'spamassassin --lint' to make sure there aren't any hidden
configuration errors. Then run an example message with the problem
through 'spamassassin -t -D 2>&1 | less +/relay.*trusted' and look at
the result. There should be a clue in or around that debug output
information that will say what is happening.

Then run

  spamassassin --lint

to make sure there aren't any hidden configuration errors. Then run
an example message with the problem through (piped to stdin)

  spamassassin -t -D 2>&1 | less +/relay.*trusted

and look at the result. There should be a clue in or around that
debug output information that will say what is happening.

Bob