syslog-ng-users July 2011 archive
Main Archive Page > Month Archives  > syslog-ng-users archives
syslog-ng-users: Re: [syslog-ng] [PATCH] afmongodb: Support syst

Re: [syslog-ng] [PATCH] afmongodb: Support system-installed libmongo-client at configure time.

From: Gergely Nagy <algernon_at_nospam>
Date: Thu Jul 14 2011 - 11:55:13 GMT
To: Syslog-ng users' and developers' mailing list <>

Balazs Scheidler <> writes:

>> The downside is that it requires glib >= 2.16, slightly newer than what
>> syslog-ng requires right now, but still pretty damn old (released
>> 2008-03-10, so more than 3 years old).
> I've updated the internal copy (just pushed out the submodules change),
> however I'd be interested how much it depends on glib 2.16? Our build
> systems have 2.14 deployed, and our last attempt to update that failed,
> because newer glib is not trivial to compile on some of our non-Linux
> platforms (at least in its pure, upstream form, sunfreeware/perzl
> carries a quite recent glib).
> So is the glib dependency easy to get rid of, or it is something more
> inherent?

It's needed for authentication (not used by the mongodb destination at
the moment, but I plan to add authentication support later), and later
on for GridFS (but that's irrelevant for syslog-ng). I suppose I can add
a little compat layer that'd fall back to OpenSSL if glib is too old.

It's only some MD5 stuff I use from 2.16. For 0.1.3 (ETA: July 22nd),
I'll drop back to requiring glib >= 2.12 only, and using either
GChecksum from glib >= 2.16 if present, or OpenSSL otherwise.

All in all, it's reasonably easy to get rid of the hard 2.16 dependency,
and I'll do that for the next release.

However, libmongo-client will depend on either glib >= 2.16 OR OpenSSL,
unless you have strong objections, in which case I'll make the depending
parts of it optional (but I'd like to not do that, if possible).

-- |8] ______________________________________________________________________________ Member info: Documentation: FAQ: